3. 加工可能なデータについて

3-1 | DXF データを用いて加工する

EMARFのDXFアップロード機能を使うと、DXFと呼ばれるデータ形式(2Dデータのみ対応)の設計データをEMARF上にアップロードすることで、その形状のとおりに木材を加工することができます。

対応する設計ソフト(代表例)

DXF形式のデータの書き出しに対応した代表的なCAD/デザインソフトには、以下のものがあります(記載していないものでも、DXFデータ書き出しに対応していれば問題ありません)。
  • Adobe Illustrator
  • Jw_cad
  • Rhinoceros
  • Vectorworks
  • AutoCAD
  • Fusion 360
  • SketchUp  etc...

基本的な使用方法

①DXFファイルを準備します。Upload可能なファイルの条件として3点あります。

1.閉じた線であること
2.内側の線がはみ出していないこと
3.ポケット加工などの掘り込みをする場合はエンドミル径が入るサイズの線であること

②ログイン後プラグインDLの下にあるDXF Uploadを押します。

③アップロード画面に切り替わるのでファイルを選択またはドラッグアンドドロップしてください。

④プルダウンメニューから板の厚みを選択し、完了を押します。

以降の操作は、Web画面の操作方法の章を参照ください。

ポケット加工(貫通させない加工)の場合の使用方法

DXFアップロード機能では、レイヤ名を指定の方法に従って編集することで、貫通させない加工(ポケット加工)を行うことができます。
以下それぞれの形状のパターンの場合の、レイヤ名の指定の仕方について説明します。
例としてAdobe Illustratorを使用していますが、基本的にはどの設計ツールでも変わりません。

①単一のポケットの場合

【イメージ】
【手順】
  1. 1.
    「po○○mm」という文字をタイトルに含めたレイヤーを作成する(○○には彫りたい深さを板厚を超えない範囲で入力、その他の文字が含まれていてもOK)
  2. 2.
    ポケット加工をしたい部分の外形線を、上記で作成したレイヤーに割り当てる
例:12mmの深さのポケットを作成したい場合

②ポケットの内側を切り抜きたい場合

【イメージ】
【手順】
  1. 1.
    ①の手順に従い、任意の深さのポケットのパスを作成する
  2. 2.
    1.で作成したポケットの内側に、切り抜きたい形状のパスを作成する(レイヤー名にpo○○mmがないと、すべてその内側は切り抜く加工として認識される)
例:12mmの深さのポケットの内側を、任意の形状で切り抜きたい場合

③ポケットの内側にポケットがある場合

【イメージ】
【手順】
  1. 1.
    ①の手順に従い、任意の深さのポケットのパスを作成する
  2. 2.
    1.で作成したポケットのパスの内側に、任意の形状のパスを作成する
  3. 3.
    「po○○mm」という文字をタイトルに含めたレイヤーを作成する
  4. 4.
    3.で作成したレイヤーに、2.で作成したパスを割り当てる
例:12mmの深さのポケットの内側に、16mmの深さのポケットを作成したい場合

④ポケットの内側に島形状を残したい場合(島ポケット)

【イメージ】
【手順】
  1. 1.
    ①の手順に従い、任意の深さのポケットのパスを作成する
  2. 2.
    1.で作成したポケットのパス内側に、島状に残したい形状のパスを作成する
  3. 3.
    「po0mm」という文字をタイトルに含めたレイヤーを作成する
  4. 4.
    2.で作成したパスを、3.で作成したレイヤーに割り当てる ※0mmの深さのポケット=削らずにそのまま残すと理解するとわかりやすい
例:12mmのポケットの内側に、島形状を残したい場合

注意事項・トラブルシューティング

  • DXF以外のデータはアップロードできません。
  • 2Dパスのみを含むDXFデータにし、3Dパスや面(Solid)を含まないようにしてください。
  • 線は閉じた線(線の始点と終点がつながっている線)にしてください。
  • 繋がっている線同士は必ず連結させる必要があります。
  • ポケットの線は外形線にちょうど重なるか外形線よりも内側に配置してください。
  • パーツは規定の板サイズに収まる大きさにしてください。具体的な板サイズはドキュメントで確認することができます。
  • 外形線よりも内側にある線のうち、ポケット指定のない線は切り抜き線として認識されます。
  • フィレットは作成する必要があります。

3-2 | プラグインを用いて加工する

プラグインのインストール (Win / Mac)

Windows

Rhinoceros

プラグイン最新版:v2.1.0 対応OS:Windows 対応バージョン:Rhinoceros6,7 機能:接合部生成 / 平面展開 / オフセット / フィレット / CAM
チュートリアル動画
Windows版
  1. 1.
    事前にRhinocerosを最新版にアップデートします。
ファイル>>プロパティを押します。
ドキュメントのプロパティ>>更新と統計より新しいバージョンかどうかを「今すぐ確認する」を押して確認します。
2. ウェブサイトよりプラグインインストーラー(.rhiファイル)をダウンロードします。
インストーラーを起動し、インストール先を指定して「次へ」をクリックします。「インストールが正常に完了しました」のメッセージが表示されたら、インストーラーを終了します。
3. Rhinocerosを起動します
次の章にお進みください

Fusion360

プラグイン最新版:v1.0.5 対応OS:Windows 対応バージョン: 機能:フィレット(外部プラグインを利用する場合〇)/溝ぼり・ポケット加工 / CAM
Windows版(Mac版もチュートリアル動画を準備中ですが、基本的にはwindowsと同じです)
チュートリアル動画
インストール手順

1. ウェブサイトよりプラグインインストーラー(.msiファイル)をダウンロードします。
2. インストーラーを起動し、インストール先を指定して「次へ」をクリックします。「インストールが正常に完了しました」のメッセージが表示されたら、インストーラーを終了します。
以上でWindows版プラグインのインストールは完了です。
3. Dogboneフィレットの外部プラグインもインストールしておきましょう。
Fusion360には既にフィレット機能がプラグインとして既に開発され、誰でもダウンロードできるように公開されています。(フィレットとは...?
こちらからダウンロードできます。
※なお、以下のプラグインに関してVUILDでは開発を行っておりません。そのため、不具合の報告に対する対応はできかねます。
WindowsとMacそれぞれダウンロードできます
extractを押してダウンロードします
4.. Fusion360 を起動します
Emarf Addin installと表示されていればインストール完了です
フィレットのプラグインとビューキューブのY軸が上となっているかどうか確認します
※Y軸が高さ方向になるようにして設計を進めてください。
また、外部のソフトで作ったファイルをFusion360で開いて編集すると、送信しても破損したファイルで送信されてしまう問題があります。そのため、最初からFusion360でモデリングしたもののみご利用ください。
次の章にお進みください

AutoCAD

プラグイン最新版:v1.0.5 対応OS:Windows 対応バージョン:AutoCAD2019 機能:フィレット / CAM
チュートリアル動画
Windows版
インストール方法

AutoCAD2019/2020にインストールをする方法

  1. 1.
    https://emarf.co/download よりWin版のZipファイルをダウンロードします。
  2. 2.
    ダウンロードしたZipファイルを解凍します。
  3. 3.
    インストーラーと設定用regファイルをそれぞれダブルクリックで起動します。
  4. 4.
    起動したインストーラーウィンドウの手順にしたがってプラグインをインストールします。
  5. 5.
    AutoCADを再起動し、EmarfCAM.dllファイルを常に読み込むを選択します。

AutoCAD2019/2020以外のバージョンにインストールする方法

  1. 1.
    https://emarf.co/download よりWin版のZipファイルをダウンロードします。
  2. 2.
    ダウンロードしたZipファイルを解凍します。
  3. 3.
    インストーラーと設定用regファイルをそれぞれダブルクリックで起動します。
  4. 4.
    起動したインストーラーウィンドウの手順にしたがってプラグインをインストールします。
  5. 5.
    C:\ProgramData\Autodesk\ApplicationPlugins\EmarfCAD.Bundleフォルダ内の全てのファイルのプロパティを確認し、セキュリティのチェックを許可します。
  6. 6.
    C:\ProgramData\Autodesk\ApplicationPlugins\EmarfCAD.Bundle\PackageContents.xmlファイルをバージョンに合わせて編集します。(以下の画像を参照)
    AutoCAD 2015 --> SeriesMin="R20.0" SeriesMax="R20.0"
    AutoCAD 2016:SeriesMin="R20.1" SeriesMax="R22.0"
    AutoCAD 2017:SeriesMin="R20.1" SeriesMax="R22.0"
    AutoCAD 2018:SeriesMin="R20.1" SeriesMax="R22.0"
    AutoCAD 2019:SeriesMin="R23.0" SeriesMax="R23.1"
    AutoCAD 2020:SeriesMin="R23.0" SeriesMax="R23.1"
    AutoCAD 2021:SeriesMin="R24.0" SeriesMax="R24.0"
  7. 7.
    AutoCADを再起動し、EmarfCAM.dllファイルを常に読み込むを選択します。
次の章にお進みください

Vectorworks

プラグイン最新版:v1.1.1 対応OS:Windows / Mac 対応バージョン:VectorWorks 2020 機能:CAM
チュートリアル動画
Windows版

インストール手順

VW2020 バージョン

  1. 1.
    https://emarf.co/download よりzipファイルをダウンロードします
  2. 2.
    ダウンロードしたzipファイルを解凍します
  3. 3.
    インストーラー(win: msiファイル、mac: pkgファイル)を起動します
  4. 4.
    手順に沿ってインストール、VWを再起動します
  5. 5.
    「ツール>作業画面>現在の作業画面を編集」を選択します
  6. 6.
    画面左のEmarf>EmarfCAMPluginを、画面右の任意のメニューにドラッグ&ドロップし、OKします
  7. 7.
    追加したメニューにEmarfが追加されていることを確認します

VW 2019以前のバージョン

  1. 1.
    2020バージョンのインストール方法3.まで共通です
  2. 2.
    インストーラー起動、途中でインストールフォルダの指定があるので「参照」より任意のフォルダを選択してください。
    ex: 2015年版であれば 「/Vectorworks/2015/Plug-ins」に変更します
  3. 3.
    そのまま進んでインストールを完了します
  4. 4.
    VWを再起動。「ツール>プラグインマネージャ」を開きます
  5. 5.
    「新規」からプラグインの新規作成ウィンドウを開き、名前を「Emarf」に変更します。ラジオボタンはメニュー(M)のままです。
  6. 6.
    作成されたプラグインをダブルクリック、スクリプトエディタを開きます
  7. 7.
    「スクリプト言語」をpythonスクリプトに変更、以下テキストを入力します
    1
    import main
    2
    main.execute()
    Copied!
  8. 8.
    スクリプトオプションから環境パスの設定を行い、「追加」を押します。
  9. 9.
    (win)C:\Users\$USERNAME\AppData\Roaming\Nemetschek\Vectorworks\$YEARS\
    Plug-ins\emarf_vectorworks
    を選択しOKで出ます。
  10. 10.
    ここからは2020バージョンのインストール方法5.と共通です

事前準備

オブジェクトのクラス設定

外周線と内周線をそれぞれ「Interior」「Exterior」というクラスを新規で作成し、オブジェクトを格納します。

Emarfの起動

加工したいオブジェクトを選択しEmarfを押して起動してください。以下のようなダイアログが表示されます。
次の章にお進みください

Illustrator

プラグイン最新版:v1.1.1 対応OS:Windows 対応バージョン:Illustrator 2019, 2020, 2021 機能:フィレット/溝ぼり・ポケット加工 / CAM

チュートリアル動画

インストール手順

  1. 1.
    ウェブサイトよりプラグインをダウンロードします。
2.ファイルを解凍します。
3.EMARF Irustrator. msi ファイルを実行します。
4. 手順にならってダウンロードを進めます。

事前準備

  1. 1.
    Illustratorを立ち上げます。(バージョンは2019~CCで確認済みです)
  2. 2.
    メニューバーのウィンドウ>エクステンション>CAM APIを選択します。
  3. 3.
    EMARFのウィンドウが立ち上がったことを確認します。

Mac

Rhinoceros

プラグイン最新版:v2.1.0 対応OS: 対応バージョン:Rhinoceros6,7 機能:接合部生成 / 平面展開 / オフセット / フィレット / CAM
チュートリアル動画
  1. 1.
    事前にRhinocerosを最新版にアップデートします。
ファイル>>プロパティを押します。
ドキュメントのプロパティ>>更新と統計より新しいバージョンかどうかを「今すぐ確認する」を押して確認します。
2. ウェブサイトよりプラグインインストーラー(.rhiファイル)をダウンロードします。
インストーラーを起動し、インストール先を指定して「次へ」をクリックします。「インストールが正常に完了しました」のメッセージが表示されたら、インストーラーを終了します。
3. Rhinocerosを起動します
次の章にお進みください

Fusion360

プラグイン最新版:v1.0.5 対応OS:Windows 対応バージョン: 機能:フィレット(外部プラグインを利用する場合〇)/溝ぼり・ポケット加工 / CAM
(Mac版もチュートリアル動画を準備中ですが、基本的にはwindowsと同じです)
チュートリアル動画

インストール手順

1. ウェブサイトよりプラグインインストーラー(.msiファイル)をダウンロードします。
2. ウェブサイトよりプラグイン(.zipファイル)をダウンロードします。ZIPファイルを解凍するとEmarfCAMという名前のフォルダが出てきます。
3. Finderで~/Library/Application Support/Autodesk/Autodesk Fusion 360/API/AddInsを開き、EmarfCAMフォルダをAddinsの中に配置します。
以上でMac版プラグインのインストールは完了です。
Libraryフォルダはホームフォルダの直下にあります。Libraryフォルダが見つからない場合はFinderのデスクトップメニューバーから、Optionを押しながら Go (移動) を開くとLibraryフォルダを見つけることができます。
3. Dogboneフィレットの外部プラグインもインストールしておきましょう。
Fusion360には既にフィレット機能がプラグインとして既に開発され、誰でもダウンロードできるように公開されています。(フィレットとは...?
こちらからダウンロードできます。
※なお、以下のプラグインに関してVUILDでは開発を行っておりません。そのため、不具合の報告に対する対応はできかねます。
WindowsとMacそれぞれダウンロードできます
extractを押してダウンロードします
4.. Fusion360 を起動します
Emarf Addin installと表示されていればインストール完了です
フィレットのプラグインとビューキューブのY軸が上となっているかどうか確認します
※Y軸が高さ方向になるようにして設計を進めてください。
また、外部のソフトで作ったファイルをFusion360で開いて編集すると、送信しても破損したファイルで送信されてしまう問題があります。そのため、最初からFusion360でモデリングしたもののみご利用ください。
次の章にお進みください

Vectorworks

プラグイン最新版:v1.1.1 対応OS: Mac 対応バージョン:VectorWorks 2020 機能:CAM
チュートリアル動画

インストール手順

VW2020 バージョン

  1. 1.
    https://emarf.co/download よりzipファイルをダウンロードします
  2. 2.
    ダウンロードしたzipファイルを解凍します
  3. 3.
    インストーラー pkgファイルを起動します
  4. 4.
    手順に沿ってインストール、VWを再起動します
  5. 5.
    「ツール>作業画面>現在の作業画面を編集」を選択します
  6. 6.
    画面左のEmarf>EmarfCAMPluginを、画面右の任意のメニューにドラッグ&ドロップし、OKします
  7. 7.
    追加したメニューにEmarfが追加されていることを確認します

VW 2019以前のバージョン

  1. 1.
    2020バージョンのインストール方法3.まで共通です
  2. 2.
    インストーラー起動、途中でデフォルトの2020からお使いのバージョンを選択してください。
  3. 3.
    そのまま進んでインストールを完了します
  4. 4.
    VWを再起動。「ツール>プラグインマネージャ」を開きます
  5. 5.
    「新規」からプラグインの新規作成ウィンドウを開き、名前を「Emarf」に変更します。ラジオボタンはメニュー(M)のままです。
  6. 6.
    作成されたプラグインをダブルクリック、スクリプトエディタを開きます
  7. 7.
    「スクリプト言語」をpythonスクリプトに変更、以下テキストを入力します
    1
    import main
    2
    main.execute()
    Copied!
  8. 8.
    スクリプトオプションから環境パスの設定を行い、「追加」を押します。
  9. 9.
    (mac) Users/$USERNAME/Library/Application Support/Vectorworks/$YEARS/Plug-ins/emarf_vectorworks
    を選択しOKで出ます。
  10. 10.
    ここからは2020バージョンのインストール方法5.と共通です

事前準備

オブジェクトのクラス設定

外周線と内周線をそれぞれ「Interior」「Exterior」というクラスを新規で作成し、オブジェクトを格納します。

Emarfの起動

加工したいオブジェクトを選択しEmarfを押して起動してください。以下のようなダイアログが表示されます。
次の章にお進みください

Illustrator

プラグイン最新版:v1.1.1 対応OS:Mac 対応バージョン:Illustrator 2019, 2020, 2021 機能:フィレット/溝ぼり・ポケット加工 / CAM

チュートリアル動画

インストール手順

  1. 1.
    ウェブサイトよりMac版のインストーラーをダウンロードします。
  2. 2.
    ダウンロードしたインストーラーをダブルクリックで起動します。
  3. 3.
    起動したインストーラーウィンドウの手順にしたがってプラグインをインストールします。
  4. 4.
    インストールが完了したらIllustratorを起動もしくは再起動します。
インストール先は目的に合わせて「このコンピュータのすべてのユーザー用にインストール」または「自分専用にインストール」を選択します。

事前準備

  1. 1.
    Illustratorを立ち上げます。(バージョンは2019~CCで確認済みです)
  2. 2.
    メニューバーのウィンドウ>エクステンション>CAM APIを選択します。
  3. 3.
    EMARFのウィンドウが立ち上がったことを確認します。
次の章にお進みください

各種ソフトのトラブル

Rhinoceros

MacでプラグインをDLしようとすると「開発元が未確認のため開けません」というエラーが出る場合

こちらをお試しください

インストールはできたが、Rhinoを起動すると「ロード中にエラーが発生しました」というメッセージが表示される

以下に示す二つの解決方法を試してみてください。

方法1

  • コマンドからPlugInManagerを開きます
  • 「インストール」ボタンをクリックします
  • C:/Users/ユーザー名/AppData/Roaming/McNeel/Rhinoceros/6.0/Plug-ins/EmarfCAM (unique-id)の中に入っている EmarfCAM.Windows.rhp(v1.0.7以前はEmarfCAM.rhp)を選択します
  • 無事ロードできたら解決です

方法2

  • Rhinoを閉じます
  • /Users/ユーザー名/AppData/Roaming/McNeel/Rhinoceros/6.0/Plug-ins/EmarfCAM (unique-id)を削除します
  • レジストリエディタを開きます
  • HKEY_CURRENT_USER/Software/McNeel/Rhinoceros/6.0/Global Options/unique-idを削除します
  • HKEY_CURRENT_USER/Software/McNeel/Rhinoceros/6.0/Plug-Ins/unique-idを削除します
  • rhiファイルを起動してもう一度プラグインをインストールします
  • Rhinoを起動して無事ロードできたら解決です
unique-idは12f6b7a6-bcdb-11ea-8a78-f01898f17bfaのような文字列になっています。

Rhinoceros7にて

インストールツールバーが出てこない場合

方法1.Rhinocerosの更新を確認して最新版をダウンロードしてください
方法2.
  • インストーラファイル(rhi)をダブルクリックしてプラグインを6, 7用にインストール
  • Rhinoでプラグインがうまくロードされてない、あるいはツールパレットが表示されていない場合はPluginManagerコマンドでプラグインマネージャー開いてEmarfCAMがあるか確認する
  • EmarfCAMがあればLoadのチェックボックスがオンになっていることを確認する
  • EmarfCAMがない場合、一度Install Pluginボタンを押して C:\Users\ユーザー名\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins/EmarfCAM 下にあるEmarfPluginフォルダの中のrhpファイルを選択してインストールする
  • EmarfCAMがプラグインマネージャーに表示されてLoadがされている状態を確認できたらRhinoを終了する
  • C:\Users\ユーザー名\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins 下にあるEmarfPluginフォルダを削除する
  • 再度rhiファイルでプラグインをインストールする
Mac版の対応手順
以下の4つの手順を踏んでみてください。
  1. 1.
    macrhiをzipにして解凍する
  2. 2.
    rhpファイルが入っています
  3. 3.
    フォルダ名のrhp拡張子を取り除くとフォルダに変わります
  4. 4.
    そのフォルダに入っているruiをWindows版と同じように読み込ませます
もしパレットが表示されない場合は、一回プラグインに入っているコマンドをどれでも良いので一回起動し、スクショのメニューからパレットを表示してください。
ーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーー

最終更新 11d ago